Balazs Dezso <deba@inf.elte.hu> [Fri, 13 Feb 2009 13:29:28 +0100] rev 488
Fixes for MSVC 2008 in grap_adaptors.h and edge_set.h (#194)
Several renamings and changes in adaptors and edge sets
- Fixing scope usage for MSVC
- ResidualDigraph based on SubDigraph instead of FilterArcs
- Use initialize() in adaptors and edge sets
- Wrap ListDigraph for edge set tests
Alpar Juttner <alpar@cs.elte.hu> [Fri, 13 Feb 2009 15:01:09 +0000] rev 487
Change LEMON's isnan() to isNaN() for the sake of AIX/xlC
Certain xlC versions implement isnan() as a #define.
Alpar Juttner <alpar@cs.elte.hu> [Fri, 13 Feb 2009 14:56:27 +0000] rev 486
Fix in lp_base.cc targeting AIX/xlC compatibility
Alpar Juttner <alpar@cs.elte.hu> [Tue, 10 Feb 2009 17:37:59 +0000] rev 485
Merge
Alpar Juttner <alpar@cs.elte.hu> [Tue, 10 Feb 2009 17:21:26 +0000] rev 484
Set the compatibily related MSVC defines only if they has't been defined yet
Janos Tapolcai <tapolcai@tmit.bme.hu> [Tue, 10 Feb 2009 15:43:39 +0100] rev 483
Compilation bug fixed in graph_to_eps.h with VS2005 (#214)
Alpar Juttner <alpar@cs.elte.hu> [Sat, 07 Feb 2009 15:30:04 +0000] rev 482
Add missing include to time_measure.h
Alpar Juttner <alpar@cs.elte.hu> [Fri, 23 Jan 2009 16:42:07 +0000] rev 481
Merge (manually add cmake/FindGLPK.cmake to Makefile.am)
Alpar Juttner <alpar@cs.elte.hu> [Fri, 23 Jan 2009 16:30:05 +0000] rev 480
Set the proper version for CMAKE in the tarballs (made by autotools).
Akos Ladanyi <ladanyi@tmit.bme.hu> [Thu, 22 Jan 2009 10:39:13 +0000] rev 479
Enable the component-based installer
Akos Ladanyi <ladanyi@tmit.bme.hu> [Thu, 22 Jan 2009 10:39:56 +0000] rev 478
Update the lemon icon
Alpar Juttner <alpar@cs.elte.hu> [Thu, 22 Jan 2009 14:46:15 +0000] rev 477
Suppress or fix VS2008 warnings + turn off faulty tests using CMAKE (#208)
Alpar Juttner <alpar@cs.elte.hu> [Wed, 21 Jan 2009 18:18:41 +0000] rev 476
Merge
Akos Ladanyi <ladanyi@tmit.bme.hu> [Wed, 21 Jan 2009 18:06:17 +0000] rev 475
Fix 'make install' without 'make html' using CMAKE (#207)
Akos Ladanyi <ladanyi@tmit.bme.hu> [Wed, 21 Jan 2009 18:08:31 +0000] rev 474
Fix CMAKE build without GLPK
Akos Ladanyi <ladanyi@tmit.bme.hu> [Tue, 20 Jan 2009 12:23:14 +0000] rev 473
Build GLPK dependent parts with CMake too
Alpar Juttner <alpar@cs.elte.hu> [Mon, 19 Jan 2009 11:42:15 +0000] rev 472
(.hg)ignore more build-like dirs (*objs* and *build*)
Balazs Dezso <deba@inf.elte.hu> [Sun, 18 Jan 2009 17:49:08 +0100] rev 471
Fix lp indexing bug (#205)
Alpar Juttner <alpar@cs.elte.hu> [Wed, 14 Jan 2009 15:55:29 +0000] rev 470
Own support for isnan()
Alpar Juttner <alpar@cs.elte.hu> [Mon, 12 Jan 2009 13:37:37 +0000] rev 469
Merge
Balazs Dezso <deba@inf.elte.hu> [Mon, 08 Dec 2008 11:38:02 +0100] rev 468
ArcSet and EdgeSet ports from SVN 3489 (ticket #67)
Alpar Juttner <alpar@cs.elte.hu> [Mon, 12 Jan 2009 13:18:03 +0000] rev 467
Merge
Peter Kovacs <kpeter@inf.elte.hu> [Mon, 12 Jan 2009 09:53:12 +0100] rev 466
Rename graph adaptors with the migration script (#67)
Peter Kovacs <kpeter@inf.elte.hu> [Mon, 12 Jan 2009 08:18:04 +0100] rev 465
Rename graph_adaptor_test.cc to adaptors_test.cc (#67)
Peter Kovacs <kpeter@inf.elte.hu> [Mon, 12 Jan 2009 08:05:30 +0100] rev 464
Rename Residual to ResidualDigraph (#67)
The new name is more analogous to other adaptor names.
Peter Kovacs <kpeter@inf.elte.hu> [Mon, 12 Jan 2009 07:52:48 +0100] rev 463
Greatly extend and improve the test file for adaptors (#67)
- Add concept checks for the alterable, extendable, erasable
and clearable adaptors.
- Add test cases for modifying the underlying graphs through adaptors
whenever it is possible.
- Check the conversions between Node, Arc and Edge types.
- Add more test cases for the adaptor-specific functions and maps:
enable(), disable(), status(), forward(), backward(), CombinedArcMap,
CombinedNodeMap, ResidualCapacity etc.
- Use checkGraphIncEdgeArcLists() to simplify the test cases for
undirected graphs.
- Add test cases that use static graph structure (GridGraph) with
several adaptors combined.
- Add comments for the test cases.
Alpar Juttner <alpar@cs.elte.hu> [Mon, 12 Jan 2009 12:26:02 +0000] rev 462
Rename Lp*/Mip* to *Lp/*Mip
Alpar Juttner <alpar@cs.elte.hu> [Mon, 12 Jan 2009 12:26:01 +0000] rev 461
Remove lp_ prefix from the solver's header name