COIN-OR::LEMON - Graph Library

source: lemon-0.x/debian/rules @ 1916:e7d4eb908e87

Last change on this file since 1916:e7d4eb908e87 was 1671:3c82a0d9e0e7, checked in by Akos Ladanyi, 19 years ago

install docs in $datadir/doc/$PACKAGE

  • Property exe set to *
File size: 2.4 KB
Line 
1#!/usr/bin/make -f
2# -*- makefile -*-
3# Sample debian/rules that uses debhelper.
4# This file was originally written by Joey Hess and Craig Small.
5# As a special exception, when this file is copied by dh-make into a
6# dh-make output file, you may use that output file without restriction.
7# This special exception was added by Craig Small in version 0.37 of dh-make.
8
9# Uncomment this to turn on verbose mode.
10#export DH_VERBOSE=1
11
12
13# These are used for cross-compiling and for saving the configure script
14# from having to guess our platform (since we know it already)
15DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
16DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
17
18
19CFLAGS = -Wall -g
20
21ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
22        CFLAGS += -O0
23else
24        CFLAGS += -O2
25endif
26
27config.status: configure
28        dh_testdir
29        # Add here commands to configure the package.
30        CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
31
32
33build: build-stamp
34
35build-stamp:  config.status
36        dh_testdir
37
38        # Add here commands to compile the package.
39        $(MAKE)
40        #docbook-to-man debian/lemon.sgml > lemon.1
41
42        touch build-stamp
43
44clean:
45        dh_testdir
46        dh_testroot
47        rm -f build-stamp
48
49        # Add here commands to clean up after the build process.
50        -$(MAKE) distclean
51ifneq "$(wildcard /usr/share/misc/config.sub)" ""
52        cp -f /usr/share/misc/config.sub config.sub
53endif
54ifneq "$(wildcard /usr/share/misc/config.guess)" ""
55        cp -f /usr/share/misc/config.guess config.guess
56endif
57
58
59        dh_clean
60
61install: build
62        dh_testdir
63        dh_testroot
64        dh_clean -k
65        dh_installdirs
66
67        # Add here commands to install the package into debian/lemon.
68        $(MAKE) install DESTDIR=$(CURDIR)/debian/lemon
69
70
71# Build architecture-independent files here.
72binary-indep: build install
73# We have nothing to do by default.
74
75# Build architecture-dependent files here.
76binary-arch: build install
77        dh_testdir
78        dh_testroot
79        dh_installchangelogs ChangeLog
80        dh_installdocs
81        dh_installexamples
82#       dh_install
83#       dh_installmenu
84#       dh_installdebconf       
85#       dh_installlogrotate
86#       dh_installemacsen
87#       dh_installpam
88#       dh_installmime
89#       dh_installinit
90#       dh_installcron
91#       dh_installinfo
92#       dh_installman
93        dh_link
94        dh_strip
95        dh_compress
96        dh_fixperms
97#       dh_perl
98#       dh_python
99#       dh_makeshlibs
100        dh_installdeb
101        dh_shlibdeps
102        dh_gencontrol
103        dh_md5sums
104        dh_builddeb
105
106binary: binary-indep binary-arch
107.PHONY: build clean binary-indep binary-arch binary install
Note: See TracBrowser for help on using the repository browser.