Several changes. \n If new map is added to mapstorage it emits signal with the name of the new map. This was important, because from now on not only tha mapwin should be updated. \n Furthermore algobox gets a pointer to mapstorage instead of only the mapnames from it. This is important because without it it would be complicated to pass all of the required maps to algobox.
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
13 # These are used for cross-compiling and for saving the configure script
14 # from having to guess our platform (since we know it already)
15 DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
16 DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
21 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
27 config.status: configure
29 # Add here commands to configure the package.
30 CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
35 build-stamp: config.status
38 # Add here commands to compile the package.
40 #docbook-to-man debian/lemon.sgml > lemon.1
49 # Add here commands to clean up after the build process.
51 ifneq "$(wildcard /usr/share/misc/config.sub)" ""
52 cp -f /usr/share/misc/config.sub config.sub
54 ifneq "$(wildcard /usr/share/misc/config.guess)" ""
55 cp -f /usr/share/misc/config.guess config.guess
67 # Add here commands to install the package into debian/lemon.
68 $(MAKE) install DESTDIR=$(CURDIR)/debian/lemon
71 # Build architecture-independent files here.
72 binary-indep: build install
73 # We have nothing to do by default.
75 # Build architecture-dependent files here.
76 binary-arch: build install
79 dh_installchangelogs ChangeLog
106 binary: binary-indep binary-arch
107 .PHONY: build clean binary-indep binary-arch binary install