Query functions have been implemented for GLPK (CPLEX breaks at the moment, I guess): These functions include:
retrieving one element of the coeff. matrix
retrieving one element of the obj function
lower bd for a variable
upper bound for a variable
lower and upper bounds for a row (these can not be handled separately at the moment)
direction of the optimization (is_max() function)
4 Maintainer: LEMON Development Team <etik-ol@cs.elte.hu>
5 Build-Depends: debhelper (>= 4.0.0), glpk, libgnomecanvasmm-2.6-dev
6 Standards-Version: 3.6.1
10 Depends: ${shlibs:Depends}, ${misc:Depends}, libgnomecanvasmm-2.6
11 Description: A C++ template library aimed at combinatorial optimization tasks.
12 LEMON stands for Library of Efficient Models and
13 Optimization in Networks. It is a C++ template
14 library aimed at combinatorial optimization tasks,
15 especially those working with graphs and networks.