Mon, 08 Dec 2008 11:38:02 +0100ArcSet and EdgeSet ports from SVN 3489 (ticket #67)
Balazs Dezso <deba@inf.elte.hu> [Mon, 08 Dec 2008 11:38:02 +0100] rev 468
ArcSet and EdgeSet ports from SVN 3489 (ticket #67)

Mon, 12 Jan 2009 13:18:03 +0000Merge
Alpar Juttner <alpar@cs.elte.hu> [Mon, 12 Jan 2009 13:18:03 +0000] rev 467
Merge

Mon, 12 Jan 2009 09:53:12 +0100Rename graph adaptors with the migration script (#67)
Peter Kovacs <kpeter@inf.elte.hu> [Mon, 12 Jan 2009 09:53:12 +0100] rev 466
Rename graph adaptors with the migration script (#67)

Mon, 12 Jan 2009 08:18:04 +0100Rename graph_adaptor_test.cc to adaptors_test.cc (#67)
Peter Kovacs <kpeter@inf.elte.hu> [Mon, 12 Jan 2009 08:18:04 +0100] rev 465
Rename graph_adaptor_test.cc to adaptors_test.cc (#67)

Mon, 12 Jan 2009 08:05:30 +0100Rename Residual to ResidualDigraph (#67)
Peter Kovacs <kpeter@inf.elte.hu> [Mon, 12 Jan 2009 08:05:30 +0100] rev 464
Rename Residual to ResidualDigraph (#67)
The new name is more analogous to other adaptor names.

Mon, 12 Jan 2009 07:52:48 +0100Greatly extend and improve the test file for adaptors (#67)
Peter Kovacs <kpeter@inf.elte.hu> [Mon, 12 Jan 2009 07:52:48 +0100] rev 463
Greatly extend and improve the test file for adaptors (#67)

- Add concept checks for the alterable, extendable, erasable
and clearable adaptors.
- Add test cases for modifying the underlying graphs through adaptors
whenever it is possible.
- Check the conversions between Node, Arc and Edge types.
- Add more test cases for the adaptor-specific functions and maps:
enable(), disable(), status(), forward(), backward(), CombinedArcMap,
CombinedNodeMap, ResidualCapacity etc.
- Use checkGraphIncEdgeArcLists() to simplify the test cases for
undirected graphs.
- Add test cases that use static graph structure (GridGraph) with
several adaptors combined.
- Add comments for the test cases.

Mon, 12 Jan 2009 12:26:02 +0000Rename Lp*/Mip* to *Lp/*Mip
Alpar Juttner <alpar@cs.elte.hu> [Mon, 12 Jan 2009 12:26:02 +0000] rev 462
Rename Lp*/Mip* to *Lp/*Mip

Mon, 12 Jan 2009 12:26:01 +0000Remove lp_ prefix from the solver's header name
Alpar Juttner <alpar@cs.elte.hu> [Mon, 12 Jan 2009 12:26:01 +0000] rev 461
Remove lp_ prefix from the solver's header name

Mon, 12 Jan 2009 12:25:55 +0000Bypass warnings with gcc 4.3
Alpar Juttner <alpar@cs.elte.hu> [Mon, 12 Jan 2009 12:25:55 +0000] rev 460
Bypass warnings with gcc 4.3

Tue, 02 Dec 2008 22:48:28 +0100Thorough redesign of the LP/MIP interface (#44)
Balazs Dezso <deba@inf.elte.hu> [Tue, 02 Dec 2008 22:48:28 +0100] rev 459
Thorough redesign of the LP/MIP interface (#44)

- Redesigned class structure
- Redesigned iterators
- Some functions in the basic interface redesigned
- More complete setting functions
- Ray retrieving functions
- Lot of improvements
- Cplex common env
- CLP macro definition to config.h.in
- Update lp.h to also use soplex and clp
- Remove default_solver_name
- New solverName() function in solvers
- Handle exceptions for MipCplex test
- Rename tolerance parameter to epsilon
- Rename MapIt to CoeffIt
- Lot of documentation improvements
- Various bugfixes