Tue, 02 Dec 2008 22:48:28 +0100Thorough redesign of the LP/MIP interface (#44)
Balazs Dezso <deba@inf.elte.hu> [Tue, 02 Dec 2008 22:48:28 +0100] rev 459
Thorough redesign of the LP/MIP interface (#44)

- Redesigned class structure
- Redesigned iterators
- Some functions in the basic interface redesigned
- More complete setting functions
- Ray retrieving functions
- Lot of improvements
- Cplex common env
- CLP macro definition to config.h.in
- Update lp.h to also use soplex and clp
- Remove default_solver_name
- New solverName() function in solvers
- Handle exceptions for MipCplex test
- Rename tolerance parameter to epsilon
- Rename MapIt to CoeffIt
- Lot of documentation improvements
- Various bugfixes

Tue, 02 Dec 2008 21:40:33 +0100Port LP and MIP solvers from SVN -r3509 (#44)
Balazs Dezso <deba@inf.elte.hu> [Tue, 02 Dec 2008 21:40:33 +0100] rev 458
Port LP and MIP solvers from SVN -r3509 (#44)

Mon, 12 Jan 2009 12:22:11 +0000Add HAVE_LP and HAVE_MIP #defines
Alpar Juttner <alpar@cs.elte.hu> [Mon, 12 Jan 2009 12:22:11 +0000] rev 457
Add HAVE_LP and HAVE_MIP #defines

Mon, 12 Jan 2009 12:22:11 +0000Ignore standard .m4 files
Alpar Juttner <alpar@cs.elte.hu> [Mon, 12 Jan 2009 12:22:11 +0000] rev 456
Ignore standard .m4 files

Sun, 11 Jan 2009 15:09:53 +0000Merge
Alpar Juttner <alpar@cs.elte.hu> [Sun, 11 Jan 2009 15:09:53 +0000] rev 455
Merge

Sun, 11 Jan 2009 15:03:14 +0000Update lemon/adaptors.h's header to 2009
Alpar Juttner <alpar@cs.elte.hu> [Sun, 11 Jan 2009 15:03:14 +0000] rev 454
Update lemon/adaptors.h's header to 2009

Sun, 11 Jan 2009 15:24:20 +0100Remove non-checked subgraph adaptors + rename parameters (#67)
Peter Kovacs <kpeter@inf.elte.hu> [Sun, 11 Jan 2009 15:24:20 +0100] rev 453
Remove non-checked subgraph adaptors + rename parameters (#67)

Fri, 09 Jan 2009 14:03:25 +0100Rename convenience functions in subgraph adaptors (#67)
Peter Kovacs <kpeter@inf.elte.hu> [Fri, 09 Jan 2009 14:03:25 +0100] rev 452
Rename convenience functions in subgraph adaptors (#67)

- Rename hide(), unHide() to disable(), enable().
- Add new set function status(Item, bool).
- Remove hidden() and add status() instead
(which returns the opposite value).

Fri, 09 Jan 2009 12:54:27 +0100Various doc improvements for graph adaptors (#67)
Peter Kovacs <kpeter@inf.elte.hu> [Fri, 09 Jan 2009 12:54:27 +0100] rev 451
Various doc improvements for graph adaptors (#67)

- Add notes about modifying the adapted graphs through adaptors
if it is possible.
- Add notes about the possible conversions between the Node, Arc and
Edge types of the adapted graphs and the adaptors.
- Hide the default values for template parameters (describe them
in the doc instead).
- More precise docs for template parameters.
- More precise docs for member functions.
- Add docs for important public typedefs.
- Unify the docs of the adaptors.
- Add \relates commands for the creator functions.
- Fixes and improvements the module documentation.

Fri, 09 Jan 2009 12:43:52 +0100Add creator functions for Residual and Residual::ResidualCapacity (#67)
Peter Kovacs <kpeter@inf.elte.hu> [Fri, 09 Jan 2009 12:43:52 +0100] rev 450
Add creator functions for Residual and Residual::ResidualCapacity (#67)