Thu, 05 Nov 2009 08:39:49 +0100Merge #179 (Port the min mean cycle algorithms)
Alpar Juttner <alpar@cs.elte.hu> [Thu, 05 Nov 2009 08:39:49 +0100] rev 817
Merge #179 (Port the min mean cycle algorithms)

Tue, 18 Aug 2009 10:08:28 +0200Add tolerance() functions for MMC classes (#179)
Peter Kovacs <kpeter@inf.elte.hu> [Tue, 18 Aug 2009 10:08:28 +0200] rev 816
Add tolerance() functions for MMC classes (#179)

Wed, 12 Aug 2009 09:45:15 +0200Separate group for the min mean cycle classes (#179)
Peter Kovacs <kpeter@inf.elte.hu> [Wed, 12 Aug 2009 09:45:15 +0200] rev 815
Separate group for the min mean cycle classes (#179)

Tue, 11 Aug 2009 22:52:35 +0200Simplify comparisons in min mean cycle classes (#179)
Peter Kovacs <kpeter@inf.elte.hu> [Tue, 11 Aug 2009 22:52:35 +0200] rev 814
Simplify comparisons in min mean cycle classes (#179)
using extreme INF values instead of bool flags.

Tue, 11 Aug 2009 21:53:39 +0200Add HartmannOrlin algorithm class (#179)
Peter Kovacs <kpeter@inf.elte.hu> [Tue, 11 Aug 2009 21:53:39 +0200] rev 813
Add HartmannOrlin algorithm class (#179)
This algorithm is an improved version of Karp's original method,
it applies an efficient early termination scheme.
The interface is the same as Karp's and Howard's interface.

Tue, 11 Aug 2009 20:55:40 +0200Add Karp algorithm class (#179)
Peter Kovacs <kpeter@inf.elte.hu> [Tue, 11 Aug 2009 20:55:40 +0200] rev 812
Add Karp algorithm class (#179)
based on the MinMeanCycle implementation in SVN -r3436.
The interface is reworked to be the same as Howard's interface.

Mon, 10 Aug 2009 14:50:57 +0200Rename MinMeanCycle to Howard (#179)
Peter Kovacs <kpeter@inf.elte.hu> [Mon, 10 Aug 2009 14:50:57 +0200] rev 811
Rename MinMeanCycle to Howard (#179)

Fri, 07 Aug 2009 14:52:40 +0200Add a detailed test file for MinMeanCycle and fix test_tools.h (#179)
Peter Kovacs <kpeter@inf.elte.hu> [Fri, 07 Aug 2009 14:52:40 +0200] rev 810
Add a detailed test file for MinMeanCycle and fix test_tools.h (#179)

Thu, 06 Aug 2009 20:31:04 +0200Rename cyclePath() to cycle() in MinMeanCycle (#179)
Peter Kovacs <kpeter@inf.elte.hu> [Thu, 06 Aug 2009 20:31:04 +0200] rev 809
Rename cyclePath() to cycle() in MinMeanCycle (#179)

Thu, 06 Aug 2009 20:28:28 +0200Traits class + named parameters for MinMeanCycle (#179)
Peter Kovacs <kpeter@inf.elte.hu> [Thu, 06 Aug 2009 20:28:28 +0200] rev 808
Traits class + named parameters for MinMeanCycle (#179)

- Add a Traits class defining LargeValue, Tolerance, Path types.
LargeValue is used for internal computations, it is 'long long'
if the length type is integer, otherwise it is 'double'.
- Add named template parameters for LargeValue and Path types.
- Improve numerical stability: remove divisions from the internal
computations. If the arc lengths are integers, then all used
values are integers (except for the cycleMean() query function,
of course).