1 | The LEMON-STABLE project -*- mode: org; -*- |
---|
2 | |
---|
3 | #+TYP_TODO: TODO Ákos Alpár Balázs Márk Jácint ALL DONE |
---|
4 | |
---|
5 | * TODO Release 0.6 before any major changes in svn-trunk |
---|
6 | ** Do we really need it? |
---|
7 | * Ákos Separate GLEMON from LEMON |
---|
8 | ** It should go to https://hugo.cs.elte.hu/svn/glemon/trunk |
---|
9 | ** Probably the main lemon trunk should also be renamed to |
---|
10 | https://hugo.cs.elte.hu/svn/lemon/trunk |
---|
11 | * Ákos Change to single makefile |
---|
12 | * Ákos Set up a compilation environment in branches/lemon-1.0 |
---|
13 | ** Copy from the trunk |
---|
14 | ** Comment out the missing files |
---|
15 | * TODO Revise/Clarify/Extend the naming conventions |
---|
16 | ** setXYZ/getXYZ issue |
---|
17 | ** class-local variables vs. access functions to them |
---|
18 | ** standard naming rules for function/template parameters |
---|
19 | ** template<class X> vs. template<typename X> |
---|
20 | * TODO Revise doc (globally) |
---|
21 | ** Revise the module structures |
---|
22 | ** Revise 'Related Pages' |
---|
23 | *** Intro/Tutorials |
---|
24 | **** What are missing? |
---|
25 | **** Aren't there some duplications? |
---|
26 | * Revise Basic components |
---|
27 | ** Graph Structures |
---|
28 | *** ALL Directed Graphs |
---|
29 | **** Do we need concepts other than StaticGraph? |
---|
30 | ***** If don't, rename StaticGraph to Graph |
---|
31 | **** Revise doc |
---|
32 | **** Revise check files |
---|
33 | *** TODO Undirected Graph |
---|
34 | **** Revise doc |
---|
35 | **** Revise check files |
---|
36 | *** TODO Bipartite Graphs |
---|
37 | **** Revise doc |
---|
38 | **** Revise check files |
---|
39 | * TODO Revise Tools |
---|
40 | ** Graph Adaptors |
---|
41 | *** Revise doc |
---|
42 | *** Revise check files |
---|
43 | ** Map Structures |
---|
44 | *** Special Maps |
---|
45 | *** Map Adaptors |
---|
46 | ** Graph I/O |
---|
47 | *** Change @uedgeset @edgeset (???) |
---|
48 | ** Graph Drawing |
---|
49 | ** xy |
---|
50 | *** Doesn't follow the naming convention |
---|
51 | *** Should normSquare() be a member function? |
---|
52 | *** What about bezier.h |
---|
53 | *** What about linear transformations? |
---|
54 | *** What about xyz.h? |
---|
55 | * TODO Revise Algorithms |
---|
56 | * TODO Revise repository maintenance files |
---|
57 | ** Related files |
---|
58 | *** AUTHORS |
---|
59 | *** ChangeLog |
---|
60 | *** COPYING |
---|
61 | *** INSTALL |
---|
62 | *** LICENSE |
---|
63 | *** NEWS |
---|
64 | *** README |
---|
65 | * TODO Revise demos |
---|
66 | ** What are missing? |
---|
67 | ** What are superfluous? |
---|
68 | ** Documentation |
---|
69 | ** Add links from the doc of a data struct/alg to the related demo |
---|
70 | *** Create a \demo macro similar to \sa |
---|