Balazs Dezso <deba@inf.elte.hu> [Sun, 04 Oct 2009 00:28:42 +0200] rev 793
Faster add row operation (#203)
One virtual function call instead of more
Peter Kovacs <kpeter@inf.elte.hu> [Fri, 02 Oct 2009 17:03:43 +0200] rev 792
Improve bib2dox.py using \section for entiries (#184)
Alpar Juttner <alpar@cs.elte.hu> [Sat, 26 Sep 2009 10:15:49 +0200] rev 791
Integrate bib2dox.py into the build environments (#184)
Peter Kovacs <kpeter@inf.elte.hu> [Sat, 26 Sep 2009 10:15:49 +0200] rev 790
Add bib->dox converter and initial references.bib (#184)
Alpar Juttner <alpar@cs.elte.hu> [Wed, 30 Sep 2009 08:41:06 +0200] rev 789
Merge #311
Alpar Juttner <alpar@cs.elte.hu> [Wed, 30 Sep 2009 08:36:43 +0200] rev 788
Merge
Peter Kovacs <kpeter@inf.elte.hu> [Tue, 29 Sep 2009 10:21:51 +0200] rev 787
Add a warning for List(Di)Graph::Snapshot (#311)
and extend tests for snapshots
Peter Kovacs <kpeter@inf.elte.hu> [Mon, 28 Sep 2009 12:48:44 +0200] rev 786
Modify the implementation of ListDigraph::ArcIt (#311)
The new implementation is based on out-arc iteration (like
ListGraph::ArcIt) instead of in-arc iteration to make it
consistent with the documentation.
Peter Kovacs <kpeter@inf.elte.hu> [Sun, 23 Aug 2009 11:13:21 +0200] rev 785
Much better implementation for node splitting (#311)
in ListDigraph. This solution is the same as the one that
is used in SmartDigraph. It is much faster and does not
invalidate any iterator like the former implementation.
Peter Kovacs <kpeter@inf.elte.hu> [Sun, 23 Aug 2009 11:11:49 +0200] rev 784
Add a resize() function to HypercubeGraph (#311)
just like the similar functions in other static graph structures,
and extend the test files to check these functions.
Peter Kovacs <kpeter@inf.elte.hu> [Sun, 23 Aug 2009 11:10:40 +0200] rev 783
Add reserve functions to ListGraph and SmartGraph (#311)
ListDigraph and SmartDigraph already have such functions.
Peter Kovacs <kpeter@inf.elte.hu> [Sun, 23 Aug 2009 11:09:22 +0200] rev 782
Doc improvements, fixes and unifications for graphs (#311)
Peter Kovacs <kpeter@inf.elte.hu> [Sun, 23 Aug 2009 11:07:50 +0200] rev 781
Doc improvements and unification for graph concepts (#311)
Alpar Juttner <alpar@cs.elte.hu> [Tue, 29 Sep 2009 09:25:23 +0200] rev 780
Copyright notices added to scripts
Alpar Juttner <alpar@cs.elte.hu> [Tue, 29 Sep 2009 09:25:00 +0200] rev 779
Simple interactive bootstrap script
Alpar Juttner <alpar@cs.elte.hu> [Sat, 26 Sep 2009 07:21:54 +0200] rev 778
Merge #298
Alpar Juttner <alpar@cs.elte.hu> [Sat, 26 Sep 2009 07:16:22 +0200] rev 777
Merge
Peter Kovacs <kpeter@inf.elte.hu> [Fri, 25 Sep 2009 11:58:34 +0200] rev 776
Small improvements for NetworkSimplex (#298)
Peter Kovacs <kpeter@inf.elte.hu> [Thu, 02 Jul 2009 17:36:29 +0200] rev 775
Add a parameter to control arc mixing in NS (#298)
Peter Kovacs <kpeter@inf.elte.hu> [Wed, 01 Jul 2009 16:34:01 +0200] rev 774
Small improvements in NS pivot rules (#298)
Alpar Juttner <alpar@cs.elte.hu> [Sat, 26 Sep 2009 07:08:10 +0200] rev 773
Merge #302
Peter Kovacs <kpeter@inf.elte.hu> [Fri, 25 Sep 2009 12:24:16 +0200] rev 772
Add creator functions for IdMap and RangeIdMap (#302)
Peter Kovacs <kpeter@inf.elte.hu> [Fri, 25 Sep 2009 12:22:42 +0200] rev 771
Rename ValueIterator to ValueIt in graph maps (#302)
but keep ValueIterator as an alias in CrossRefMap
(only for reverse compatibility).
Peter Kovacs <kpeter@inf.elte.hu> [Fri, 25 Sep 2009 12:12:37 +0200] rev 770
Extend maps_test.cc (#302)
Peter Kovacs <kpeter@inf.elte.hu> [Sun, 02 Aug 2009 17:22:43 +0200] rev 769
Doc improvements for several graph maps (#302)
Peter Kovacs <kpeter@inf.elte.hu> [Sun, 02 Aug 2009 13:44:45 +0200] rev 768
Merge
Peter Kovacs <kpeter@inf.elte.hu> [Thu, 23 Jul 2009 18:13:59 +0200] rev 767
Improvements for graph maps (#302)
- Add a count() function to CrossRefMap.
- Add tests for IdMap and RangeIdMap.
- Extend tests for CrossRefMap.
- Improve the doc.
Alpar Juttner <alpar@cs.elte.hu> [Fri, 25 Sep 2009 09:33:09 +0200] rev 766
Merge
Peter Kovacs <kpeter@inf.elte.hu> [Thu, 20 Aug 2009 20:34:30 +0200] rev 765
Also check ReferenceMapTag in concept checks (#312)
Alpar Juttner <alpar@cs.elte.hu> [Fri, 25 Sep 2009 09:13:03 +0200] rev 764
Merge
Peter Kovacs <kpeter@inf.elte.hu> [Sun, 02 Aug 2009 12:40:20 +0200] rev 763
Small doc improvements (#304)
Alpar Juttner <alpar@cs.elte.hu> [Fri, 25 Sep 2009 09:06:32 +0200] rev 762
Merge
Peter Kovacs <kpeter@inf.elte.hu> [Fri, 24 Jul 2009 11:07:52 +0200] rev 761
Rearrange modules (#303)
Peter Kovacs <kpeter@inf.elte.hu> [Fri, 24 Jul 2009 10:27:40 +0200] rev 760
Small doc improvements
Alpar Juttner <alpar@cs.elte.hu> [Mon, 31 Aug 2009 20:27:38 +0200] rev 759
Merge
Peter Kovacs <kpeter@inf.elte.hu> [Wed, 08 Jul 2009 17:47:01 +0200] rev 758
Unify member names in heaps (#299)
The following renamings are made.
Public members:
- UnderFlowPriorityError -> PriorityUnderflowError
("underflow" is only one word)
Private members:
- bubble_up() -> bubbleUp()
- bubble_down() -> bubbleDown()
- second_child() -> secondChild()
- makeroot() -> makeRoot()
- relocate_last() -> relocateLast()
- data -> _data
- boxes -> _boxes
Peter Kovacs <kpeter@inf.elte.hu> [Wed, 08 Jul 2009 17:22:36 +0200] rev 757
Move the heaps to a separate group (#299)
Peter Kovacs <kpeter@inf.elte.hu> [Wed, 08 Jul 2009 17:21:30 +0200] rev 756
Improve and unify the documentation of heaps (#299)
and avoid a warning in SimpleBucketHeap::operator[].
Alpar Juttner <alpar@cs.elte.hu> [Mon, 31 Aug 2009 10:03:23 +0200] rev 755
Merge
Peter Kovacs <kpeter@inf.elte.hu> [Fri, 24 Jul 2009 01:07:45 +0200] rev 754
Much faster implementation for BinomHeap (#301)
Peter Kovacs <kpeter@inf.elte.hu> [Mon, 20 Jul 2009 19:06:39 +0200] rev 753
Smarter bubbleDown() in K-ary heaps (#301)
Peter Kovacs <kpeter@inf.elte.hu> [Fri, 10 Jul 2009 09:17:13 +0200] rev 752
Small improvements in heap implementations (#301)
Peter Kovacs <kpeter@inf.elte.hu> [Fri, 10 Jul 2009 09:15:22 +0200] rev 751
Make K a template parameter in KaryHeap (#301)
Peter Kovacs <kpeter@inf.elte.hu> [Thu, 09 Jul 2009 04:07:08 +0200] rev 750
Improve and unify the doc + names in the new heaps (#301)
Peter Kovacs <kpeter@inf.elte.hu> [Thu, 09 Jul 2009 02:39:47 +0200] rev 749
Bug fix in PairingHeap::pop() (#301)
Peter Kovacs <kpeter@inf.elte.hu> [Thu, 09 Jul 2009 02:38:01 +0200] rev 748
Add fourary, k-ary, pairing and binomial heaps (#301)
These structures were implemented by Dorian Batha.
Alpar Juttner <alpar@cs.elte.hu> [Mon, 31 Aug 2009 08:32:25 +0200] rev 747
Merge
Peter Kovacs <kpeter@inf.elte.hu> [Mon, 03 Aug 2009 00:54:04 +0200] rev 746
Add negativeCycle() function to BellmanFord (#51)
Peter Kovacs <kpeter@inf.elte.hu> [Mon, 03 Aug 2009 00:52:45 +0200] rev 745
Add a detailed test file for BellmanFord (#51)
Peter Kovacs <kpeter@inf.elte.hu> [Sun, 02 Aug 2009 13:24:46 +0200] rev 744
Improvements and unifications for BellmanFord (#51)
- Rework the function type interface to fit to dijkstra().
- Rename named template parameters (Def* -> Set*).
- Rename some private member variables
(to start with an underscore).
- Simplify template parameter names.
- Many unifications and improvements in the doc.
Peter Kovacs <kpeter@inf.elte.hu> [Fri, 24 Jul 2009 23:19:43 +0200] rev 743
Port Bellman-Ford algorithm from SVN -r3524 (#51)
Alpar Juttner <alpar@cs.elte.hu> [Mon, 31 Aug 2009 08:25:33 +0200] rev 742
Merge
Peter Kovacs <kpeter@inf.elte.hu> [Tue, 21 Jul 2009 22:43:31 +0200] rev 741
Improvements for iterable maps (#73)
Balazs Dezso <deba@inf.elte.hu> [Sat, 27 Jun 2009 13:07:26 +0200] rev 740
Port iterable maps from SVN 3509 (#73)
Alpar Juttner <alpar@cs.elte.hu> [Mon, 31 Aug 2009 07:22:26 +0200] rev 739
Merge
Peter Kovacs <kpeter@inf.elte.hu> [Mon, 03 Aug 2009 14:00:21 +0200] rev 738
Bug fix + extension in the rename script (#305)
Alpar Juttner <alpar@cs.elte.hu> [Mon, 31 Aug 2009 07:12:58 +0200] rev 737
Merge
Peter Kovacs <kpeter@inf.elte.hu> [Tue, 18 Aug 2009 10:35:35 +0200] rev 736
Test file + doc improvements (#307)
Peter Kovacs <kpeter@inf.elte.hu> [Tue, 18 Aug 2009 10:24:31 +0200] rev 735
Bug fix in Preflow and Circulation (#307)
Alpar Juttner <alpar@cs.elte.hu> [Thu, 20 Aug 2009 22:52:16 +0200] rev 734
Merge
Alpar Juttner <alpar@cs.elte.hu> [Thu, 20 Aug 2009 22:52:03 +0200] rev 733
Merge
Peter Kovacs <kpeter@inf.elte.hu> [Thu, 20 Aug 2009 18:37:36 +0200] rev 732
Add missing 'explicit' keywords (#311)
Peter Kovacs <kpeter@inf.elte.hu> [Thu, 23 Jul 2009 18:09:41 +0200] rev 731
Fix the implementation and doc of CrossRefMap (#302)
- Handle multiple values correctly with std::multimap.
- Clarify the problematic points in the doc.
- Add some basic tests for the class.
Balazs Dezso <deba@inf.elte.hu> [Thu, 11 Jun 2009 23:13:24 +0200] rev 730
Unification of names in heaps (#50)
Balazs Dezso <deba@inf.elte.hu> [Thu, 11 Jun 2009 22:16:11 +0200] rev 729
Simplified implementation of bucket heaps (#50)
Balazs Dezso <deba@inf.elte.hu> [Thu, 11 Jun 2009 22:11:29 +0200] rev 728
Port remaining heaps from SVN -r 3509 (#50)
- FibHeap
- RadixHeap
- BucketHeap
- SimpleBucketHeap
Akos Ladanyi <ladanyi@tmit.bme.hu> [Fri, 29 May 2009 17:46:48 +0100] rev 727
Set the version to 'hg-tip' if everything fails
Akos Ladanyi <ladanyi@tmit.bme.hu> [Fri, 29 May 2009 12:44:37 +0100] rev 726
Minor CMake improvements
* Use the empty ELSE(), ENDIF(), ENDMACRO(), etc. syntax since this improves
readability and requires less typing.
* Use FIND_PACKAGE() instead of INCLUDE().
* Use the value of CMAKE_COMMAND variable instead of cmake, since this works
even if cmake is not in the PATH.
Akos Ladanyi <ladanyi@tmit.bme.hu> [Fri, 29 May 2009 11:40:53 +0100] rev 725
Put the version string into config.h
Also make it possible to set the version using the LEMON_VERSION environment
variable, and use the hg revision as version string in case this variable is
unset.
Akos Ladanyi <ladanyi@tmit.bme.hu> [Fri, 29 May 2009 10:35:05 +0100] rev 724
Fix the check for the 'long long' type
Akos Ladanyi <ladanyi@tmit.bme.hu> [Thu, 28 May 2009 19:46:43 +0100] rev 723
Change the label of the html project in Visual Studio
Akos Ladanyi <ladanyi@tmit.bme.hu> [Wed, 27 May 2009 20:12:08 +0100] rev 722
Generate and install LEMONConfig.cmake
Akos Ladanyi <ladanyi@tmit.bme.hu> [Wed, 27 May 2009 13:08:47 +0100] rev 721
Add tools/CMakeLists.txt to the tarball
Akos Ladanyi <ladanyi@tmit.bme.hu> [Tue, 26 May 2009 17:49:10 +0100] rev 720
Rename documentation install folder from 'docs' to 'html'
Akos Ladanyi <ladanyi@tmit.bme.hu> [Tue, 26 May 2009 17:47:51 +0100] rev 719
Remove duplications from doc/CMakeLists.txt
Akos Ladanyi <ladanyi@tmit.bme.hu> [Thu, 28 May 2009 12:11:50 +0100] rev 718
Suppress MSVC warnings using pragmas (#295)
Peter Kovacs <kpeter@inf.elte.hu> [Wed, 13 May 2009 10:42:26 +0200] rev 717
Add artificial addNode() function to the arc/edge set classes
Peter Kovacs <kpeter@inf.elte.hu> [Tue, 12 May 2009 20:08:23 +0200] rev 716
Avoid Intel C++ Compiler warnings
Peter Kovacs <kpeter@inf.elte.hu> [Tue, 12 May 2009 17:57:49 +0200] rev 715
Disable Visual Studio warning C4503
Alpar Juttner <alpar@cs.elte.hu> [Tue, 12 May 2009 15:55:00 +0100] rev 714
Add lemon/config.h.cmake to the tarball
Alpar Juttner <alpar@cs.elte.hu> [Tue, 12 May 2009 15:02:18 +0100] rev 713
Resolve GCC-4.4 warnings & fix ambiguous op=() in graph_components.h
Alpar Juttner <alpar@cs.elte.hu> [Tue, 12 May 2009 11:49:13 +0100] rev 712
Update NEWS file
Peter Kovacs <kpeter@inf.elte.hu> [Tue, 12 May 2009 12:08:06 +0200] rev 711
Extend min cost flow test file + check dual costs (#291)
Peter Kovacs <kpeter@inf.elte.hu> [Tue, 12 May 2009 12:06:40 +0200] rev 710
Fix the GEQ/LEQ handling in NetworkSimplex + improve doc (#291)
- Fix the optimality conditions for the GEQ/LEQ form.
- Fix the initialization of the algortihm. It ensures correct
solutions and it is much faster for the inequality forms.
- Fix the pivot rules to search all the arcs that have to be
allowed to get in the basis.
- Better block size for the Block Search pivot rule.
- Improve documentation of the problem and move it to a
separate page.
Alpar Juttner <alpar@cs.elte.hu> [Mon, 11 May 2009 16:38:21 +0100] rev 709
Merge
Peter Kovacs <kpeter@inf.elte.hu> [Sat, 09 May 2009 16:47:26 +0200] rev 708
Remove bits/base_extender.h, which is not used at all (#288)
Peter Kovacs <kpeter@inf.elte.hu> [Mon, 11 May 2009 17:04:40 +0200] rev 707
Move list and edge sets to the graph module (#290)
Alpar Juttner <alpar@cs.elte.hu> [Mon, 11 May 2009 15:48:37 +0100] rev 706
Merge
Peter Kovacs <kpeter@inf.elte.hu> [Mon, 11 May 2009 16:42:42 +0200] rev 705
Change the explanation of the acronym LEMON (#289)
Peter Kovacs <kpeter@inf.elte.hu> [Sat, 09 May 2009 16:39:59 +0200] rev 704
Change Graph::Edge -> Graph::Arc inheritance to conversion (#283)
Balazs Dezso <deba@inf.elte.hu> [Thu, 07 May 2009 10:46:49 +0200] rev 703
Change Undirector::Edge -> Undirector::Arc inheritance to conversion (#283)
Alpar Juttner <alpar@cs.elte.hu> [Fri, 08 May 2009 16:21:06 +0100] rev 702
Fix the faulty merge of unify-sources.sh in [586b65073025]
Peter Kovacs <kpeter@inf.elte.hu> [Fri, 08 May 2009 13:15:29 +0200] rev 701
Doc fixes for lgf-gen (#282)
Alpar Juttner <alpar@cs.elte.hu> [Thu, 07 May 2009 12:21:00 +0100] rev 700
Merge
Alpar Juttner <alpar@cs.elte.hu> [Thu, 07 May 2009 12:19:41 +0100] rev 699
Merge
Peter Kovacs <kpeter@inf.elte.hu> [Thu, 07 May 2009 02:07:59 +0200] rev 698
Small doc improvements (#257)
Balazs Dezso <deba@inf.elte.hu> [Thu, 07 May 2009 11:53:49 +0200] rev 697
Fix glp_prob definition (#286)
Peter Kovacs <kpeter@inf.elte.hu> [Wed, 06 May 2009 14:46:05 +0200] rev 696
Add a test file for the connectivity functions (#285)
The Euler tools have a separate test file.
Peter Kovacs <kpeter@inf.elte.hu> [Wed, 06 May 2009 14:44:05 +0200] rev 695
Doc improvements and fixes for connectivity tools (#285)
And add loopFree(), parallelFree(), simpleGraph() to the module doc.
Peter Kovacs <kpeter@inf.elte.hu> [Wed, 06 May 2009 14:37:44 +0200] rev 694
Bug fixes in connectivity.h (#285)
- Bug fix in tree().
- Rename simpleDigraph() to simpleGraph() (it works for both
directed and undirected graphs).
- Possibly faster implementation for parallelFree() and
simpleGraph().
Alpar Juttner <alpar@cs.elte.hu> [Wed, 29 Apr 2009 19:22:14 +0100] rev 693
Merge
Akos Ladanyi <ladanyi@tmit.bme.hu> [Wed, 29 Apr 2009 16:15:29 +0100] rev 692
Add the solver libraries to lemon.pc.in (#281)
Alpar Juttner <alpar@cs.elte.hu> [Wed, 29 Apr 2009 17:48:41 +0100] rev 691
Merge
Alpar Juttner <alpar@cs.elte.hu> [Wed, 29 Apr 2009 17:48:18 +0100] rev 690
Resolve gcc-4.3 warning in lemon/network_simplex.h
Peter Kovacs <kpeter@inf.elte.hu> [Wed, 29 Apr 2009 16:54:27 +0200] rev 689
Less map copying in NetworkSimplex (#234)
- The graph is copied in the constructor instead of the init() function.
It must not be modified after the class is constructed.
- The maps are copied once (instead of twice).
- Remove FlowMap, PotentialMap typedefs and flowMap(), pontentialMap()
setter functions.
- flowMap() and potentialMap() query functions copy the values into the
given map (reference) instead of returning a const reference to a
previously constructed map.
Peter Kovacs <kpeter@inf.elte.hu> [Wed, 29 Apr 2009 14:25:51 +0200] rev 688
Rename Flow to Value in the flow algorithms (#266)
We agreed that using Flow for the value type is misleading, since
a flow should be rather a function on the arcs, not a single value.
This patch reverts the changes of [dacc2cee2b4c] for Preflow and
Circulation.
Peter Kovacs <kpeter@inf.elte.hu> [Wed, 29 Apr 2009 03:15:24 +0200] rev 687
Support negative costs and bounds in NetworkSimplex (#270)
* The interface is reworked to support negative costs and bounds.
- ProblemType and problemType() are renamed to
SupplyType and supplyType(), see also #234.
- ProblemType type is introduced similarly to the LP interface.
- 'bool run()' is replaced by 'ProblemType run()' to handle
unbounded problem instances, as well.
- Add INF public member constant similarly to the LP interface.
* Remove capacityMap() and boundMaps(), see also #266.
* Update the problem definition in the MCF module.
* Remove the usage of Circulation (and adaptors) for checking feasibility.
Check feasibility by examining the artifical arcs instead (after solving
the problem).
* Additional check for unbounded negative cycles found during the
algorithm (it is possible now, since negative costs are allowed).
* Fix in the constructor (the value types needn't be integer any more),
see also #254.
* Improve and extend the doc.
* Rework the test file and add test cases for negative costs and bounds.
Alpar Juttner <alpar@cs.elte.hu> [Wed, 29 Apr 2009 16:55:27 +0100] rev 686
Merge
Akos Ladanyi <ladanyi@tmit.bme.hu> [Tue, 28 Apr 2009 11:25:47 +0100] rev 685
Check the version number in FindGLPK (#277)
Akos Ladanyi <ladanyi@tmit.bme.hu> [Mon, 27 Apr 2009 18:05:04 +0100] rev 684
Add GLPK_ROOT_DIR variable to FindGLPK (#277)
Akos Ladanyi <ladanyi@tmit.bme.hu> [Tue, 28 Apr 2009 11:55:43 +0100] rev 683
Link libm and libpthread if using CPLEX (#277)
Akos Ladanyi <ladanyi@tmit.bme.hu> [Mon, 27 Apr 2009 18:03:18 +0100] rev 682
Add CPLEX_ROOT_DIR variable to FindCPLEX (#277)
Akos Ladanyi <ladanyi@tmit.bme.hu> [Tue, 28 Apr 2009 14:47:25 +0100] rev 681
Look for COIN libraries with and without the lib prefix too (#277)
This is necessary because on Windows when built using autotools the COIN
libraries are named in UNIX style, i.e. libCbc.lib insetad of Cbc.lib.
Alpar Juttner <alpar@cs.elte.hu> [Wed, 29 Apr 2009 15:54:30 +0100] rev 680
Merge
Alpar Juttner <alpar@cs.elte.hu> [Wed, 29 Apr 2009 15:52:08 +0100] rev 679
Merge
Akos Ladanyi <ladanyi@tmit.bme.hu> [Tue, 28 Apr 2009 16:44:48 +0100] rev 678
Remove superfluous HAVE_CONFIG_H (#278)
Akos Ladanyi <ladanyi@tmit.bme.hu> [Tue, 28 Apr 2009 16:49:57 +0100] rev 677
Add cbc.h to lemon/Makefile.am (#279)
Balazs Dezso <deba@inf.elte.hu> [Tue, 28 Apr 2009 12:54:59 +0200] rev 676
Fix Makefile.am EXTRA_DIST (#276)
Alpar Juttner <alpar@cs.elte.hu> [Tue, 28 Apr 2009 14:01:00 +0100] rev 675
Merge
Akos Ladanyi <ladanyi@tmit.bme.hu> [Tue, 28 Apr 2009 13:51:34 +0100] rev 674
Merge and extend the fix of #275