COIN-OR::LEMON - Graph Library

Opened 11 years ago

Closed 10 years ago

#2 closed enhancement (fixed)

_newLp() and _copyLp() implementation in CPLEX

Reported by: Alpar Juttner Owned by: Balazs Dezso
Priority: minor Milestone: LEMON 1.1 release
Component: core Version: svn trunk
Keywords: cplex, lp Cc:
Revision id:

Description

_newLp() and _copyLp() creates a completely new CPLEX environment and put the new problem into it. It should rather go into the same environment.

This ticket is a copy of report #2 of the old bug tracking system. It refers to svn trunk -r2424.

Change History (8)

comment:1 Changed 11 years ago by Alpar Juttner

Keywords: cplex added; cplec removed
Milestone: Post 1.0

comment:2 Changed 11 years ago by Balazs Dezso

Owner: changed from Alpar Juttner to Balazs Dezso

comment:3 Changed 10 years ago by anonymous

Iron decorates your home. They have a wide variety of design, assuring that you will find a special one for display at home. The metal stai http://www.hebei-railings.cn/

comment:4 Changed 10 years ago by Balazs Dezso

Status: newassigned

comment:5 in reply to:  description Changed 10 years ago by Alpar Juttner

Replying to alpar:

_newLp() and _copyLp() creates a completely new CPLEX environment and put the new problem into it. It should rather go into the same environment.

This ticket is a copy of report #2 of the old bug tracking system. It refers to svn trunk -r2424.

Isn't this question satisfactorily solved by [ed54c0d13df0]?

comment:6 Changed 10 years ago by Balazs Dezso

It is solved in the LP redesign. However, for single thread applications a static CplexEnv? might be better solution than current reference counted.

comment:7 in reply to:  6 Changed 10 years ago by Alpar Juttner

Replying to deba:

It is solved in the LP redesign. However, for single thread applications a static CplexEnv? might be better solution than current reference counted.

What would be the advantage of it?

Is't it possible that someone wants to use two environments even in a single thread application? E.g. one may have two problem instances which require different solver settings.

comment:8 Changed 10 years ago by Balazs Dezso

Resolution: fixed
Status: assignedclosed

The issue is already solved.

Note: See TracTickets for help on using tickets.