COIN-OR::LEMON - Graph Library

Opened 10 years ago

Closed 10 years ago

#260 closed defect (fixed)

lp_test and mip_test seem to succeed despite CPLEX license problems

Reported by: Akos Ladanyi Owned by: Alpar Juttner
Priority: minor Milestone: LEMON 1.1 release
Component: core Version: hg main
Keywords: Cc:
Revision id: b53a9068e3e4

Description

lp_test and mip_test print a message and succeed in case CPLEX is enabled but the license file is not found. The problem is that in case using CMake the printed message is not visible, so it makes one think that the CPLEX LP/MIP interface was tested and found to be OK.

Attachments (1)

3cbddc293cf9.patch (1.2 KB) - added by Balazs Dezso 10 years ago.
Force lp check

Download all attachments as: .zip

Change History (5)

comment:1 in reply to:  description ; Changed 10 years ago by Balazs Dezso

Replying to ladanyi:

lp_test and mip_test print a message and succeed in case CPLEX is enabled but the license file is not found. The problem is that in case using CMake the printed message is not visible, so it makes one think that the CPLEX LP/MIP interface was tested and found to be OK.

It is possible to enforce the CPLEX checking if you define LEMON_FORCE_CPLEX_CHECK macro (for example, with -D compiler option).

comment:2 in reply to:  1 Changed 10 years ago by Alpar Juttner

Replying to deba:

It is possible to enforce the CPLEX checking if you define LEMON_FORCE_CPLEX_CHECK macro (for example, with -D compiler option).

Why is it a bad idea to do it by default?

Changed 10 years ago by Balazs Dezso

Attachment: 3cbddc293cf9.patch added

Force lp check

comment:3 Changed 10 years ago by Balazs Dezso

Patch [3cbddc293cf9] forces the cplex check.

comment:4 Changed 10 years ago by Alpar Juttner

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.