COIN-OR::LEMON - Graph Library

Opened 11 years ago

Closed 11 years ago

#262 closed defect (fixed)

Connectivity tools are missing from the doc

Reported by: Peter Kovacs Owned by: Peter Kovacs
Priority: major Milestone: LEMON 1.1 release
Component: documentation Version: hg main
Keywords: Cc: Akos Ladanyi
Revision id: 99a31b399b59

Description

All the tools in connectivity.h are missing from the doc. Either the graph_prop group should be renamed to connectivity in groups.dox and in euler.h or graph_prop should be used in connectivity.h. Which one do you prefer?

Attachments (1)

7c12061bd271.patch (64.8 KB) - added by Peter Kovacs 11 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 11 years ago by Alpar Juttner

Component: coredocumentation

comment:2 in reply to:  description ; Changed 11 years ago by Alpar Juttner

Replying to kpeter:

All the tools in connectivity.h are missing from the doc. Either the graph_prop group should be renamed to connectivity in groups.dox and in euler.h or graph_prop should be used in connectivity.h. Which one do you prefer?

That module is currently called "Connectivity and Other Graph Properties", which title is just perfect IMHO.

However, a lot of nice figures available in the 0.x are missing, see http://lemon.cs.elte.hu/pub/doc/latest-svn/a00846.html

comment:3 in reply to:  2 ; Changed 11 years ago by Peter Kovacs

Replying to alpar:

That module is currently called "Connectivity and Other Graph Properties", which title is just perfect IMHO.

I see. But what name should be used for the internal references (e.g. \ingroup commands): conncetivity or graph_prop? In connectivity.h the first one is used, but in euler.h and groups.doc the second one is used, that's why all the tools in connectivity.h are missing. It is matter of detail, but the same name must be used everywhere.

However, a lot of nice figures available in the 0.x are missing, see http://lemon.cs.elte.hu/pub/doc/latest-svn/a00846.html

Yes, and the references are also removed. Was there any other reason for that except for avoiding doxygen warnings?

The following image files should be ported and the references should be put to connectivity.h again.

  • bipartite_partitions.eps
  • connected_components.eps
  • edge_biconnected_components.eps
  • node_biconnected_components.eps
  • strongly_connected_components.eps

comment:4 in reply to:  3 Changed 11 years ago by Alpar Juttner

Replying to kpeter:

Replying to alpar:

That module is currently called "Connectivity and Other Graph Properties", which title is just perfect IMHO.

I see. But what name should be used for the internal references (e.g. \ingroup commands): conncetivity or graph_prop?

Chose whatever name you want. I don't care.

Yes, and the references are also removed. Was there any other reason for that except for avoiding doxygen warnings?

No.

Changed 11 years ago by Peter Kovacs

Attachment: 7c12061bd271.patch added

comment:5 Changed 11 years ago by Peter Kovacs

Cc: Akos Ladanyi added

[7c12061bd271] ports some images and adds them to the doc of connectivity tools. It also fixes the problem with different module names.

However the generated .png images are too small and they should be rotated (using portrait view instead of landscape view). How could it be solved (to work with both build systems)? Shall we modify the .eps files or the build commands for them? Could someone help in this issue?

comment:6 Changed 11 years ago by Peter Kovacs

Status: newassigned

comment:7 in reply to:  5 Changed 11 years ago by Alpar Juttner

Resolution: fixed
Status: assignedclosed

Replying to kpeter:

[7c12061bd271] ports some images and adds them to the doc of connectivity tools. It also fixes the problem with different module names.

However the generated .png images are too small and they should be rotated (using portrait view instead of landscape view). How could it be solved (to work with both build systems)?

Done in [114920bd21ef].

Note: See TracTickets for help on using tickets.