COIN-OR::LEMON - Graph Library

Opened 8 years ago

Closed 6 years ago

#387 closed defect (wontfix)

unionfind.h should be union_find.h

Reported by: Peter Kovacs Owned by: Alpar Juttner
Priority: major Milestone: LEMON 1.3 release
Component: core Version: hg main
Keywords: Cc:
Revision id:

Description

unionfind.h should be union_find.h according to our naming conventions.

Change History (5)

comment:1 Changed 8 years ago by Peter Kovacs

I see two possibilities here:

  1. Accept this incosistent name.
  2. Rename the file to the correct name and add unionfind.h whcih includes union_find.h.

Which one do you like?

comment:2 Changed 8 years ago by Peter Kovacs

Note that dheap.h is a similar problematic name. However, I could accept it more easily, since 'D' is not an ordinary word.

comment:3 in reply to:  1 ; Changed 8 years ago by Alpar Juttner

Replying to kpeter:

I see two possibilities here:

  1. Accept this incosistent name.
  2. Rename the file to the correct name and add unionfind.h whcih includes union_find.h.

Which one do you like?

I prefer accepting the inconsistent name, simply for maintenance reasons. At least, until someone is complaining about it very loudly.

comment:4 in reply to:  3 Changed 8 years ago by Peter Kovacs

Replying to alpar:

I prefer accepting the inconsistent name, simply for maintenance reasons. At least, until someone is complaining about it very loudly.

Wasn't my complaint loud enough? :)

I see your reasons, so this task could be closed with wontfix status, couldn't it?

comment:5 Changed 6 years ago by Alpar Juttner

Resolution: wontfix
Status: newclosed
Note: See TracTickets for help on using tickets.