COIN-OR::LEMON - Graph Library

Opened 6 years ago

Closed 6 years ago

#484 closed defect (fixed)

Not able to configure CMake with Visual Studio

Reported by: DK Owned by: Alpar Juttner
Priority: blocker Milestone: LEMON 1.4 release
Component: core Version: release branch 1.3
Keywords: Install Cc: Peter, Alex
Revision id:

Description

using stable build 1.3. while configuring getting error " CMake Error: Error in cmake code at D:/LemonSourceCode/lemon-1.3/CMakeLists.txt:118: Parse error. Function missing ending ")". Instead found left paren with text "(". Configuring incomplete, errors occurred!'

I check the file CMakeLists.txt and seems to be correct. I am first time user and not able to install this. I see this valuable tool for my project and dying to use this. Pl.help.

Pl. let me know if there is a workaround.

Attachments (1)

Error while Configuring CMake with VS.docx (82.8 KB) - added by DK 6 years ago.

Download all attachments as: .zip

Change History (3)

comment:1 Changed 6 years ago by Alpar Juttner

Cc: Peter Alex added

I'm unable to reproduce the problem. Could you please let me know

  • the exact version of lemon you try to compile,
  • the cmake version you use.

comment:2 Changed 6 years ago by Alpar Juttner

Resolution: fixed
Status: newclosed

Ok. This seems to be a bug in the win version of CMAKE-2.6. The workaround would too complex, so instead we require CMAKE-2.8 or better starting from version LEMON-1.3, see [e937009e4c5f].

CMAKE-2.8 should be available on all platform. However, should you be forced using CMAKE-2.6, let us now. A possible workaround is to remove the automatic default LP/MIP settings from CMakeLists.txt. A patch will be made upon request.

However a default LP/MIP setting related bug is fixed in [e00d7b681d8e], see #465.

Note: See TracTickets for help on using tickets.