COIN-OR::LEMON - Graph Library

Opened 11 years ago

Closed 11 years ago

#72 closed task (fixed)

Port radix sort algorithm

Reported by: Alpar Juttner Owned by: Balazs Dezso
Priority: major Milestone: LEMON 1.1 release
Component: core Version:
Keywords: Cc:
Revision id:

Description

i.e., the file

  • lemon/radix_sort.h

Attachments (3)

4f7224faf3bd.patch (20.3 KB) - added by Balazs Dezso 11 years ago.
31d224a3c0af.patch (18.2 KB) - added by Alpar Juttner 11 years ago.
de16f1f2d228.patch (9.4 KB) - added by Balazs Dezso 11 years ago.
Rename counterSort

Download all attachments as: .zip

Change History (13)

comment:1 Changed 11 years ago by Alpar Juttner

Milestone: LEMON 1.0 releasePost 1.0

comment:2 Changed 11 years ago by Peter Kovacs

Owner: changed from Alpar Juttner to Peter Kovacs
Status: newassigned

Changed 11 years ago by Balazs Dezso

Attachment: 4f7224faf3bd.patch added

comment:3 Changed 11 years ago by Balazs Dezso

I have uploaded the port in the patch [4f7224faf3bd].

comment:4 Changed 11 years ago by Peter Kovacs

Owner: changed from Peter Kovacs to Balazs Dezso
Status: assignednew

comment:5 Changed 11 years ago by Balazs Dezso

Status: newassigned

comment:6 in reply to:  3 ; Changed 11 years ago by Alpar Juttner

Replying to deba:

I have uploaded the port in the patch [4f7224faf3bd].

I suggest renaming counterSort() to stableRadixSort()}}, {{{countingSort() of countingRadixSort(), though I strongly prefer the first one.

What are your opinion?

Changed 11 years ago by Alpar Juttner

Attachment: 31d224a3c0af.patch added

comment:7 in reply to:  3 Changed 11 years ago by Alpar Juttner

Replying to deba:

I have uploaded the port in the patch [4f7224faf3bd].

[31d224a3c0af] contains a couple of doc improvements.

comment:8 in reply to:  6 ; Changed 11 years ago by Balazs Dezso

Replying to alpar:

Replying to deba:

I have uploaded the port in the patch [4f7224faf3bd].

I suggest renaming counterSort() to stableRadixSort()}}, {{{countingSort() of countingRadixSort(), though I strongly prefer the first one.

What are your opinion?

I think the stableRadixSort is good name, it is close to the naming of the std sorting algorithms.

Changed 11 years ago by Balazs Dezso

Attachment: de16f1f2d228.patch added

Rename counterSort

comment:9 in reply to:  8 ; Changed 11 years ago by Balazs Dezso

Replying to deba:

Replying to alpar:

Replying to deba:

I have uploaded the port in the patch [4f7224faf3bd].

I suggest renaming counterSort() to stableRadixSort()}}, {{{countingSort() of countingRadixSort(), though I strongly prefer the first one.

What are your opinion?

I think the stableRadixSort is good name, it is close to the naming of the std sorting algorithms.

I made a patch [de16f1f2d228] for renaming.

comment:10 in reply to:  9 Changed 11 years ago by Alpar Juttner

Resolution: fixed
Status: assignedclosed

Everything here is in the main branch now.

Note: See TracTickets for help on using tickets.