COIN-OR::LEMON - Graph Library

Opened 11 years ago

Closed 11 years ago

#90 closed defect (fixed)

Mac compilation error

Reported by: Alpar Juttner Owned by: Alpar Juttner
Priority: critical Milestone: LEMON 1.0 release
Component: core Version: hg main
Keywords: Cc: Akos Ladanyi
Revision id:

Description

I tried to compile Lemon on Mac, but I got both warnings and errors, see the attached compilation log.

The compiler in use was:

$ gcc --version
i686-apple-darwin9-gcc-4.0.1 (GCC) 4.0.1 (Apple Inc. build 5465)
Copyright (C) 2005 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

I used the following configuration parameters:

./configure --enable-demo

This bug is reproducible in [f4e4dbc1d467].

Attachments (1)

make.log (12.3 KB) - added by Alpar Juttner 11 years ago.
Compilation log

Download all attachments as: .zip

Change History (5)

Changed 11 years ago by Alpar Juttner

Attachment: make.log added

Compilation log

comment:1 Changed 11 years ago by Balazs Dezso

Owner: changed from Balazs Dezso to Alpar Juttner

I don't have any idea, why fails the lemon on mac, and I don't have mac environment, so I pass back the ticket. If a preprocessor output is generated, then I might be able to suggest some solution.

comment:2 Changed 11 years ago by Alpar Juttner

Status: newassigned

comment:3 Changed 11 years ago by Akos Ladanyi

Cc: Akos Ladanyi added

I think the error (./lemon/lgf_reader.h:37:30: error: lemon/lgf_writer.h: No such file or directory) was caused by lgf_writer.h missing from the tarball (see ticket #112).

comment:4 in reply to:  3 Changed 11 years ago by Alpar Juttner

Resolution: fixed
Status: assignedclosed

Replying to ladanyi:

I think the error (./lemon/lgf_reader.h:37:30: error: lemon/lgf_writer.h: No such file or directory) was caused by lgf_writer.h missing from the tarball (see ticket #112).

We checked [a5d8c039f218] on OSX and now it indeed compiles perfectly with g++-4.2.

With the default compiler (gcc 4.0.1) it compiles correctly but still emits those stupid "only defines private constructors and ..." warnings. I think this is the bug of that compiler version, not of LEMON, so I close the ticket.

Note: See TracTickets for help on using tickets.