COIN-OR::LEMON - Graph Library

LEMON is reported to compile with the following platforms and compilers

Version 1.0.x

Linux

  • GNU GCC
    • starting with 3.3, all recent compiler should be fine
      • tested with 3.3, 3.4, 4.1, 4.2, 4.3
    • version 2.95 is definitely not enough
  • Intel ICC
    • version 10.1, 11.0 works well,
      • the highest warning setting (-w2) triggers infinitely many warnings/remarks, but none of them is a valid problem.
    • older versions don't seem to work due to deficient implementation of the standards (8.0) or serious compiler bug (9.1)

M$ Windows XP

  • Visual Studio 2005, 2008
  • Cygwin
    • should work well from gcc-3.3 upwards.
Last modified 9 years ago Last modified on 01/20/09 17:27:13