COIN-OR::LEMON - Graph Library

Opened 10 years ago

Closed 10 years ago

#242 closed defect (wontfix)

LP related warnings

Reported by: Alpar Juttner Owned by: Balazs Dezso
Priority: major Milestone: LEMON 1.1 release
Component: core Version: hg main
Keywords: Cc:
Revision id: 20e3acc1a757

Description

Chgset [20e3acc1a757] turns on warnings when compiling the core library. As a result a couple of warnings has appeared in the main branchs. The first group is related to GLPK:

libtool: compile:  g++ -DHAVE_CONFIG_H -I.. -I. -Wall -W -Wall -W -Wunused -Wformat=2 -Wctor-dtor-privacy -Wnon-virtual-dtor -Wno-char-subscripts -Wwrite-strings -Wno-char-subscripts -Wreturn-type -Wcast-qual -Wcast-align -Wsign-promo -Woverloaded-virtual -ansi -fno-strict-aliasing -Wold-style-cast -Wno-unknown-pragmas -I/home/alpar/download/soplex-1.4.1/src -I/home/alpar/download/coin-or/coin-Clp-1.8/include -g -O2 -MT lemon/lemon_libemon_la-soplex.lo -MD -MP -MF lemon/.deps/lemon_libemon_la-soplex.Tpo -c ../lemon/soplex.cc -o lemon/lemon_libemon_la-soplex.o
../lemon/glpk.cc: In constructor 'lemon::GlpkLp::GlpkLp()':
../lemon/glpk.cc:534: warning: base 'lemon::GlpkBase' will be initialized after
../lemon/glpk.cc:534: warning:   base 'lemon::LpSolver'
../lemon/glpk.cc:533: warning:   when initialized here
../lemon/glpk.cc: In copy constructor 'lemon::GlpkLp::GlpkLp(const lemon::GlpkLp&)':
../lemon/glpk.cc:539: warning: base 'lemon::GlpkBase' will be initialized after
../lemon/glpk.cc:539: warning:   base 'lemon::LpSolver'
../lemon/glpk.cc:538: warning:   when initialized here
../lemon/glpk.cc: In constructor 'lemon::GlpkMip::GlpkMip()':
../lemon/glpk.cc:833: warning: base 'lemon::GlpkBase' will be initialized after
../lemon/glpk.cc:833: warning:   base 'lemon::MipSolver'
../lemon/glpk.cc:832: warning:   when initialized here
../lemon/glpk.cc: In copy constructor 'lemon::GlpkMip::GlpkMip(const lemon::GlpkMip&)':
../lemon/glpk.cc:838: warning: base 'lemon::GlpkBase' will be initialized after
../lemon/glpk.cc:838: warning:   base 'lemon::MipSolver'
../lemon/glpk.cc:837: warning:   when initialized here

The second group is in CLP:

libtool: compile:  g++ -DHAVE_CONFIG_H -I.. -I. -Wall -W -Wall -W -Wunused -Wformat=2 -Wctor-dtor-privacy -Wnon-virtual-dtor -Wno-char-subscripts -Wwrite-strings -Wno-char-subscripts -Wreturn-type -Wcast-qual -Wcast-align -Wsign-promo -Woverloaded-virtual -ansi -fno-strict-aliasing -Wold-style-cast -Wno-unknown-pragmas -I/home/alpar/download/soplex-1.4.1/src -I/home/alpar/download/coin-or/coin-Clp-1.8/include -g -O2 -MT lemon/lemon_libemon_la-clp.lo -MD -MP -MF lemon/.deps/lemon_libemon_la-clp.Tpo -c ../lemon/clp.cc -o lemon/lemon_libemon_la-clp.o
mv -f lemon/.deps/lemon_libemon_la-soplex.Tpo lemon/.deps/lemon_libemon_la-soplex.Plo
In file included from /home/alpar/download/coin-or/coin-Clp-1.8/include/coin/ClpPackedMatrix.hpp:8,
                 from /home/alpar/download/coin-or/coin-Clp-1.8/include/coin/ClpModel.hpp:16,
                 from /home/alpar/download/coin-or/coin-Clp-1.8/include/coin/ClpSimplex.hpp:15,
                 from ../lemon/clp.cc:20:
/home/alpar/download/coin-or/coin-Clp-1.8/include/coin/ClpMatrixBase.hpp:101: warning: unused parameter 'model'
/home/alpar/download/coin-or/coin-Clp-1.8/include/coin/ClpMatrixBase.hpp:101: warning: unused parameter 'baseModel'
/home/alpar/download/coin-or/coin-Clp-1.8/include/coin/ClpMatrixBase.hpp:105: warning: unused parameter 'model'
/home/alpar/download/coin-or/coin-Clp-1.8/include/coin/ClpMatrixBase.hpp:113: warning: unused parameter 'model'
/home/alpar/download/coin-or/coin-Clp-1.8/include/coin/ClpMatrixBase.hpp:128: warning: unused parameter 'model'
/home/alpar/download/coin-or/coin-Clp-1.8/include/coin/ClpMatrixBase.hpp:128: warning: unused parameter 'smallest'
/home/alpar/download/coin-or/coin-Clp-1.8/include/coin/ClpMatrixBase.hpp:128: warning: unused parameter 'largest'
/home/alpar/download/coin-or/coin-Clp-1.8/include/coin/ClpMatrixBase.hpp:128: warning: unused parameter 'check'
/home/alpar/download/coin-or/coin-Clp-1.8/include/coin/ClpMatrixBase.hpp:157: warning: unused parameter 'model'
/home/alpar/download/coin-or/coin-Clp-1.8/include/coin/ClpMatrixBase.hpp:298: warning: unused parameter 'model'
/home/alpar/download/coin-or/coin-Clp-1.8/include/coin/ClpMatrixBase.hpp:298: warning: unused parameter 'pi'
In file included from /home/alpar/download/coin-or/coin-Clp-1.8/include/coin/ClpModel.hpp:17,
                 from /home/alpar/download/coin-or/coin-Clp-1.8/include/coin/ClpSimplex.hpp:15,
                 from ../lemon/clp.cc:20:
/home/alpar/download/coin-or/coin-Clp-1.8/include/coin/CoinMessageHandler.hpp: In member function 'void CoinOneMessage::setDetail(int)':
/home/alpar/download/coin-or/coin-Clp-1.8/include/coin/CoinMessageHandler.hpp:96: warning: use of old-style cast
In file included from /home/alpar/download/coin-or/coin-Clp-1.8/include/coin/ClpModel.hpp:18,
                 from /home/alpar/download/coin-or/coin-Clp-1.8/include/coin/ClpSimplex.hpp:15,
                 from ../lemon/clp.cc:20:
/home/alpar/download/coin-or/coin-Clp-1.8/include/coin/CoinHelperFunctions.hpp: In function 'char* CoinStrdup(const char*)':
/home/alpar/download/coin-or/coin-Clp-1.8/include/coin/CoinHelperFunctions.hpp:497: warning: use of old-style cast
/home/alpar/download/coin-or/coin-Clp-1.8/include/coin/CoinHelperFunctions.hpp: In function 'double CoinDrand48(bool, unsigned int)':
/home/alpar/download/coin-or/coin-Clp-1.8/include/coin/CoinHelperFunctions.hpp:732: warning: use of old-style cast
/home/alpar/download/coin-or/coin-Clp-1.8/include/coin/CoinHelperFunctions.hpp: In member function 'double CoinThreadRandom::randomDouble() const':
/home/alpar/download/coin-or/coin-Clp-1.8/include/coin/CoinHelperFunctions.hpp:923: warning: use of old-style cast
In file included from /home/alpar/download/coin-or/coin-Clp-1.8/include/coin/ClpModel.hpp:19,
                 from /home/alpar/download/coin-or/coin-Clp-1.8/include/coin/ClpSimplex.hpp:15,
                 from ../lemon/clp.cc:20:
/home/alpar/download/coin-or/coin-Clp-1.8/include/coin/ClpParameters.hpp: In function 'void ClpDisjointCopyN(const T*, int, T*)':
/home/alpar/download/coin-or/coin-Clp-1.8/include/coin/ClpParameters.hpp:82: warning: use of old-style cast

These latter ones should probably be fixed in the CLP source then be sent the CLP people in a patch.

Change History (5)

comment:1 Changed 10 years ago by Balazs Dezso

The [9d0d7e20f76d] solves the problem. (See ticket #241)

comment:2 Changed 10 years ago by Balazs Dezso

I use Clp 1.9, and I did not get warnings during compilation.

comment:3 Changed 10 years ago by Alpar Juttner

Resolution: fixed
Status: newclosed

comment:4 in reply to:  2 Changed 10 years ago by Alpar Juttner

Resolution: fixed
Status: closedreopened

Replying to deba:

I use Clp 1.9, and I did not get warnings during compilation.

Could you double check it? For me, it emits warnings with Clp 1.9.0, too.

libtool: compile:  g++ -DHAVE_CONFIG_H -I. -I. -Wall -W -Wall -W -Wunused -Wformat=2 -Wctor-dtor-privacy -Wnon-virtual-dtor -Wno-char-subscripts -Wwrite-strings -Wno-char-subscripts -Wreturn-type -Wcast-qual -Wcast-align -Wsign-promo -Woverloaded-virtual -ansi -fno-strict-aliasing -Wold-style-cast -Wno-unknown-pragmas -I/home/alpar/download/soplex-1.4.1/src -I/home/alpar/download/coin-or/Clp-1.9.0/include -g -O2 -MT lemon/lemon_libemon_la-clp.lo -MD -MP -MF lemon/.deps/lemon_libemon_la-clp.Tpo -c lemon/clp.cc -o lemon/lemon_libemon_la-clp.o
In file included from /home/alpar/download/coin-or/Clp-1.9.0/include/coin/ClpPackedMatrix.hpp:8,
                 from /home/alpar/download/coin-or/Clp-1.9.0/include/coin/ClpModel.hpp:16,
                 from /home/alpar/download/coin-or/Clp-1.9.0/include/coin/ClpSimplex.hpp:15,
                 from lemon/clp.cc:20:
/home/alpar/download/coin-or/Clp-1.9.0/include/coin/ClpMatrixBase.hpp:101: warning: unused parameter 'model'
/home/alpar/download/coin-or/Clp-1.9.0/include/coin/ClpMatrixBase.hpp:101: warning: unused parameter 'baseModel'
/home/alpar/download/coin-or/Clp-1.9.0/include/coin/ClpMatrixBase.hpp:105: warning: unused parameter 'model'
/home/alpar/download/coin-or/Clp-1.9.0/include/coin/ClpMatrixBase.hpp:113: warning: unused parameter 'model'
/home/alpar/download/coin-or/Clp-1.9.0/include/coin/ClpMatrixBase.hpp:128: warning: unused parameter 'model'
/home/alpar/download/coin-or/Clp-1.9.0/include/coin/ClpMatrixBase.hpp:128: warning: unused parameter 'smallest'
/home/alpar/download/coin-or/Clp-1.9.0/include/coin/ClpMatrixBase.hpp:128: warning: unused parameter 'largest'
/home/alpar/download/coin-or/Clp-1.9.0/include/coin/ClpMatrixBase.hpp:128: warning: unused parameter 'check'
/home/alpar/download/coin-or/Clp-1.9.0/include/coin/ClpMatrixBase.hpp:157: warning: unused parameter 'model'
/home/alpar/download/coin-or/Clp-1.9.0/include/coin/ClpMatrixBase.hpp:298: warning: unused parameter 'model'
/home/alpar/download/coin-or/Clp-1.9.0/include/coin/ClpMatrixBase.hpp:298: warning: unused parameter 'pi'
In file included from /home/alpar/download/coin-or/Clp-1.9.0/include/coin/ClpFactorization.hpp:23,
                 from /home/alpar/download/coin-or/Clp-1.9.0/include/coin/ClpSimplex.hpp:21,
                 from lemon/clp.cc:20:
/home/alpar/download/coin-or/Clp-1.9.0/include/coin/CoinDenseFactorization.hpp:341: warning: unused parameter 'noPermute'

comment:5 Changed 10 years ago by Alpar Juttner

Resolution: wontfix
Status: reopenedclosed

The same happens with CBC-2.2.2.

The problem is probably not on our side. I created two tickets at the related projects on the COIN-OR site:

Note: See TracTickets for help on using tickets.