COIN-OR::LEMON - Graph Library

Opened 10 years ago

Closed 10 years ago

#322 closed defect (fixed)

CMAKE setup problem under windows

Reported by: Alpar Juttner Owned by: Peter Kovacs
Priority: major Milestone: LEMON 1.2 release
Component: build system Version: release branch 1.1
Keywords: Cc: kkormendi@…
Revision id: r1.1.1

Description

This problem is reported by Kristof Kormendi on the lemon-user list:

   I'm new to Lemon, and I'd like to share an issue about building Lemon using CMake under windows (if anyone interested in that).

System spec.: WinXP SP3, CMake 2.6.2, Visual Studio 2008 (9.0.21022.8.) 
(and many other software, according to the official documentation http://lemon.cs.elte.hu/trac/lemon/wiki/InstallCmake)

   If I start generating in CMake, it fails because of some missing file "LEMONConfig.cmake.in" according to the error message printed by CMake:



CMake Error: File E:/lemon-1.1.1/cmake/LEMONConfig.cmake.in does not exist.

CMake Error at CMakeLists.txt:48 (CONFIGURE_FILE):

configure_file Problem configuring file


...and also refers to a missing "stdint.h" file (see in the error log that I've attached).

And here comes Akos' answer:

On Mon, Oct 12, 2009 at 1:30 PM, Körmendi Kristóf <kkormendi@gmail.com> wrote:

>    If I start generating in CMake, it fails because of some missing file
> "LEMONConfig.cmake.in" according to the error message printed by CMake:
>
> CMake Error: File E:/lemon-1.1.1/cmake/LEMONConfig.cmake.in does not exist.
The problem is that cmake/LEMONConfig.cmake.in is missing from the
1.1.1 tarball. You can get that file here:
http://lemon.cs.elte.hu/hg/lemon-1.1/raw-file/f6bf0b2a7b63/cmake/LEMONConfig.cmake.in

I guess it must be fixed both in branch 1.1 and in the default one.

Attachments (1)

71f9c1f0d808.patch (505 bytes) - added by Akos Ladanyi 10 years ago.

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by Akos Ladanyi

Attachment: 71f9c1f0d808.patch added

comment:1 Changed 10 years ago by Akos Ladanyi

Attached a patch.

comment:2 in reply to:  1 Changed 10 years ago by Alpar Juttner

Resolution: fixed
Status: newclosed

Replying to ladanyi:

Attached a patch.

Merged to both 1.1 and default branches

Note: See TracTickets for help on using tickets.