COIN-OR::LEMON - Graph Library

Opened 10 years ago

Closed 10 years ago

#324 closed defect (invalid)

LP problem

Reported by: Peter Kovacs Owned by: Balazs Dezso
Priority: blocker Milestone: LEMON 1.2 release
Component: core Version: hg main
Keywords: Cc:
Revision id: 48fe2a46bf91

Description

Two simple test files are attached using LP. The first one compiles and works correctly using LEMON 0.x, but the second one fails using LEMON 1.x, although they are/must be equivalent. (I ran the tests on lime.cs.elte.hu.)

If the default LP solver is used (Glpk), then lp_test_1x.cpp fails. If CPLEX is used, then it terminates, but it gives bad results (zero for all primal values).

What is the problem here? Why does lp_test pass if this problem is present? Did I miss something?

Attachments (2)

lp_test_0x.cpp (592 bytes) - added by Peter Kovacs 10 years ago.
lp_test_1x.cpp (585 bytes) - added by Peter Kovacs 10 years ago.

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by Peter Kovacs

Attachment: lp_test_0x.cpp added

Changed 10 years ago by Peter Kovacs

Attachment: lp_test_1x.cpp added

comment:1 Changed 10 years ago by Balazs Dezso

I have tested with the following versions: glpk 4.38 - passed cplex 9.1 - passed soplex 1.3.0, 1.4.2 - failed clp 1.10.2 - passed

The result was 30 with problem type 3 for the passed tests. I used debian linux for the tests. The soplex gave segmentation fault, I will investigate the problem. Please, provide additional information for your tests.

comment:2 Changed 10 years ago by Balazs Dezso

Actually, I used different soplex versions for compiling the library and the executable what is the reason why the soplex failed on my tests.

If I use the right libraries, both versions (1.3.0 and 1.4.2) run properly.

comment:3 Changed 10 years ago by Peter Kovacs

Resolution: invalid
Status: newclosed

Really strange. Although I checked this test many times before I created the ticket (and it did not pass), I cannot reproduce the problem now (using the same repository and options). I can't imagine what the problem was.

Note: See TracTickets for help on using tickets.