COIN-OR::LEMON - Graph Library

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#469 closed defect (fixed)

map_test hangs with gcc 4.7/4.8

Reported by: Alpar Juttner Owned by: Alpar Juttner
Priority: blocker Milestone: LEMON 1.3 release
Component: core Version: hg main
Keywords: Cc:
Revision id: 490d89913a17

Description

The problem occur in optimized mode only (-DCMAKE_BUILD_TYPE=Release ), and only with gcc 4.7 and 4.8.

map_test passes normally with gcc 3.3 and 4.3.

Change History (3)

comment:1 Changed 5 years ago by Alpar Juttner

Resolution: fixed
Status: newclosed

The issue is fixed in [8a3fb3155dca].

comment:2 Changed 5 years ago by Alpar Juttner

Fixed in [8a3fb3155dca].

The reason was a common error - a map adaptor was initialized with a temporal object. It is a bit odd that the compiler cannot warn about this kind of mistake, especially in the light of #470.

comment:3 Changed 5 years ago by Alpar Juttner

The fix has also been backported to branch 1.2 as [e13061207f85]

Note: See TracTickets for help on using tickets.