COIN-OR::LEMON - Graph Library

Opened 8 months ago

Closed 7 months ago

#608 closed defect (fixed)

Numerical issue in Preflow with floating-point data

Reported by: Peter Kovacs Owned by: Peter Kovacs
Priority: major Milestone: LEMON 1.4 release
Component: core Version: hg main
Keywords: Cc:
Revision id:

Description

The attached patch contains the fix and test cases to reproduce the issue.

Other changes are also included to improve the test file.

Attachments (2)

608-all-538d666d8cb5--55febc0faa6d.patch (17.1 KB) - added by Peter Kovacs 8 months ago.
608-all-e0ccc1f0268f--8db773f19586.patch (17.1 KB) - added by Peter Kovacs 7 months ago.

Download all attachments as: .zip

Change History (7)

Changed 8 months ago by Peter Kovacs

comment:1 Changed 8 months ago by Peter Kovacs

Attached changesets:

comment:2 Changed 7 months ago by Alpar Juttner

I cannot apply 608-all-538d666d8cb5--55febc0faa6d.patch with --exact, mercurial says this patch is corrupt.

Changed 7 months ago by Peter Kovacs

comment:3 in reply to:  2 Changed 7 months ago by Peter Kovacs

Replying to alpar:

I cannot apply 608-all-538d666d8cb5--55febc0faa6d.patch with --exact, mercurial says this patch is corrupt.

I'm sorry, that's because of a strange issue with Mercurial (see also in #602). I recreated the patches, the new versions can be imported with --exact.

The actual bug fix is the last one. The previous ones are refactoring and extensions for the test class to allow the addition of the new test cases that reveal the bug.

Last edited 7 months ago by Peter Kovacs (previous) (diff)

comment:4 Changed 7 months ago by Alpar Juttner

It works now. Thanks.

comment:5 Changed 7 months ago by Alpar Juttner

Resolution: fixed
Status: newclosed

The bugfix has been merged to the main branch, as well as into 1.3.

Note: See TracTickets for help on using tickets.